[mysql]安装 Opencart 与 PHP 7 1.5.x

标签: MySQL PHP Apache
发布时间: 2017/4/9 23:07:47
注意事项: 本文中文内容可能为机器翻译,如要查看英文原文请点击上面连接.

这是我第一次使用 OpenCart。一个奇怪的问题出现了,当我试着在我的电脑上安装 OpenCart 1.5.4 版本。我一直都在寻找答案的论坛,但社会不是 WP 的人一样大。

enter image description here

我使用的

Linux (Elementary OS - so Debian based), with 
LAMPP installed on my machine. 
PHP 7, 
10.1.13-MariaDB (innodb_version 5.6.28-76.1),  

我没有任何问题,在我的电脑上安装 OC 2.x.x 但安装 1.5.4 给我提供了这个消息 (图像)。我试着取消注释 (,然后重新启动 lampp) extension=php_mysql.dll (php.ini 文件),但这并没有帮助。

我做错了吗?请记住,我需要安装此版本,我已经试过的 2.x (它工作正常) !

解决方法 1:

我意识到这个系统的 1.5.x 分支是很老。如果你看看安装程序文件的源,它坚持 mysql 扩展名。你可以试着黑客们,但我的猜测是,它使用 mysql_ 电话各地和整个产品不会工作。

只要你将移至 2.0.x 树,允许数据库扩展增多不少。从这个版本,你可以使用任何一种︰

mysql, mysqli, pgsql, pdo

请注意, mysql 已弃用了好一阵子,和 PHP 7 最后,它被删除。因此,你是不能够使用 OC 1.5 与 PHP 7。

你可能的解决方案是︰

  • 降级到最新 PHP5.x
  • 升级到 2.x OpenCart
官方微信
官方QQ群
31647020