[android]错误"请修复版本冲突要么通过更新版本的谷歌服务插件

发布时间: 2016/10/10 21:17:28
注意事项: 本文中文内容可能为机器翻译,如要查看英文原文请点击上面连接.

我试着在我的应用程序中使用重火力点云消息然后此错误︰

Error:Execution failed for task ':app:processDebugGoogleServices'.

请修复版本冲突要么通过更新谷歌服务插件的版本 (最新版本有关的信息是可用在https://bintray.com/android/android-tools/com.google.gms.google-services/) 或更新版本的 com.google.android.gms 到 9.0.0 版。

我的项目 gradle:

buildscript {
    repositories {
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.3'
        classpath 'com.google.gms:google-services:3.0.0'  

    }
}

allprojects {
    repositories {
        jcenter()
        mavenLocal()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

我模块 gradle:

 buildscript {
    repositories {
        maven { url 'https://maven.fabric.io/public' }
    }

    dependencies {
        classpath 'io.fabric.tools:gradle:1.+'
    }
}
apply plugin: 'com.android.application'
apply plugin: 'io.fabric'
apply plugin: 'com.google.gms.google-services'

repositories {
    maven { url 'https://maven.fabric.io/public' }
}


android {
    compileSdkVersion 24
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "com.nashkvartal"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }

    lintOptions {
        checkReleaseBuilds false
        abortOnError false
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile('com.crashlytics.sdk.android:crashlytics:2.5.5@aar') {
        transitive = true;
    }
    compile 'com.android.support:appcompat-v7:24.2.0'
    compile 'com.android.support:design:24.2.0'
    compile 'com.android.support:support-v4:24.2.0'
    compile 'com.loopj.android:android-async-http:1.4.9'
    compile 'com.google.code.gson:gson:2.6.1'
    compile 'com.facebook.android:facebook-android-sdk:4.+'
    compile 'com.vk:androidsdk:+'
    compile 'com.google.android.gms:play-services-auth:9.4.0'
    compile 'com.roughike:bottom-bar:1.3.3'
    compile 'com.google.android.gms:play-services-appindexing:9.4.0'
    compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.5'
}

我该如何解决它错误?

解决方法 1:

正如所说的错误,请降级到模块 gradle 9.0.0 版和希望它会工作︰

compile 'com.android.support:appcompat-v7:24.2.0'
compile 'com.android.support:design:24.2.0'
compile 'com.android.support:support-v4:24.2.0'
compile 'com.loopj.android:android-async-http:1.4.9'
compile 'com.google.code.gson:gson:2.6.1'
compile 'com.facebook.android:facebook-android-sdk:4.+'
compile 'com.vk:androidsdk:+'

编译 ' com.google.android.gms:play-服务-auth:9.0.0'

compile 'com.roughike:bottom-bar:1.3.3'

编译 ' com.google.android.gms:play-服务-appindexing:9.0.0'

compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.5'
赞助商